Ford Muscle Cars Tech Forum banner
1 - 3 of 3 Posts

· Premium Member
Joined
·
158 Posts
Discussion Starter · #1 ·
I just got the 393 in and running. HOLY SH_T it is fast, in third gear if I push it from 1,000 RPM to 2,500 it will spin the tires. I need to know what is a good safe initial timing for 10:1, with 93 octane. Right now I have it set for 12 degrees advanced.
Thanks
 

· Premium Member
Joined
·
158 Posts
Discussion Starter · #3 ·
It is a 1970 something block with a cast 393 crank, truck rods w/ ARP bolts, KB 393 pistons, RPM heads, scorpion 1.6 roller rockers, RPM intake, Holley 670 street avenger carb, comp cams XE274H, 1 5/8 long tubes, milodon 10 quart pan. Right now I am running a stock distributer with a pertronix and MSD coil. I have initial timing w/ vacuum set at 12*. I don't know what the total is yet, but the distributer is out from a 69 stang so I am sure it is close, or a little on the safe side. Should the 12* initial be w/ or w/out the vacuum advance?
Thanks
 

· Premium Member
Joined
·
158 Posts
Discussion Starter · #9 ·
NITROMAN I have not had it on the dyno yet, the heads are box stock, but the intake matches it almost perfect, so I didn't mess with it, and I only have 1 5/8 headders, so I cant port the exaust to much, but I did do a little polishing. I don't know how high it will rev, I haven't broken it in yet.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top