Ford Muscle Cars Tech Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I'm putting a new carburetor on my 1969 mustang 302 engine. I 'm having a problem putting the accelator cable on this neww carburetor. I have talk to edelbrock and they todl I need it part 1490 so I can connect it to my stock acelerator bracket. I can figure out how or where it should be put together any help will be apreciate it.

by the way my carburetor was loose, that it was the reason for over flowing my engine .

thank to all you

if you have a picture, of the accelerator bracket will appreciate it
 

·
Registered
Joined
·
1 Posts
I was having fits installing the cable linkage to my 351c. The part your refering to, as it relates to my engine, moves the mounting inline with the carb throttle stud, so it doesn't attach at a large angle. It aligns the two from front to bak. Hope this helps....
 

·
Registered
Joined
·
1 Posts
Does your 69 have a bracket like this:
http://img.photobucket.com/albums/v404/57fairlane/70ThrottleLinkage002.jpg

If so, I used a bracket I bought out of the chrome section at a local Autozone for around $20. Here it is mounted:
http://img.photobucket.com/albums/v404/57fairlane/70ThrottleLinkage004.jpg
I want to install the same throttle linkage on my 69-ford ranchero 302. Can you tell me where to get the throttle linkage plate, cable and any other components I would need? Also, what would it entail installing the cable to the already existing accelerator pedal/arm?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top