Ford Muscle Cars Tech Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
229 Posts
Discussion Starter · #1 ·
I bought my son an old school Mallory 11K tach with shift light and rev limiter for his 68 mustang he drag races. When I plug it in it lights up but then kills the engine. I am running a pertronix ignition in a stock ford distibutor. What do I need to make this thing work? Some kind of tach adapter?

Thanks,

Rob
 

·
Registered
Joined
·
10,327 Posts
If the unit is functioning properly, it should not affect the ignition. so a few questions:

  1. Have you tested it on another car (only power, ground, and tach (-) lead required) to verify the tach is good?
  2. Which PerTronix version?
  3. How is the PerTronix wired?
  4. How is the coil wired?
  5. How is the tach wired (all wires with colors)?
  6. Where is the rev limiter set (try setting it low to check function)?
  7. Where is the shift light set (also try low setting)?
First is to verify the tach is actually working right, then to verify the wiring of the PerTronix, coil, and the tach is good. Yes, the tach can be isolated with a tach adapter, but it shouldn't need it, and if you use an adapter the rev-limit function will not work. I am suspecting a bad tach if it's wired right.

David

[EDIT] PS: Those use little potentiometers (variable resistors) under the knobs to adjust the rev limiter and shift light. The potentiometers can get crusty over time. Try exercising them back and forth to each end of limit a bunch of times to help clean the internal contacts.
 

·
Premium Member
Joined
·
229 Posts
Discussion Starter · #4 ·
Thanks PSIG. Are you going to Pacific Raceway on May 3rd? My son is racing there with his 68 Fastback for HS drags. I think we may just get a new tach.
 

·
Registered
Joined
·
10,327 Posts
Bah. I probably won't be back in-town for that. If nothing else, we can get together at the FordMuscle BBQ though. :tup:

David
 

·
Registered
Joined
·
6,662 Posts
I am running one of those tachs in my 68 stang and used to run the pertronix ignition with no issues.My brother has the same setup in his 67..For the most part they have worked well over the last twenty years or so BUT..They do occasionally glitch for some reason.It almost seems like they sometimes will read double..Of course this will put the rpms up over the limiter and will kill the engine...Mine has only done this a couple of times but my brothers used to do it fairly often...
 
1 - 7 of 7 Posts
Top