Ford Muscle Cars Tech Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
218 Posts
Discussion Starter · #1 ·
im having several problems at the moment. im following their basic instructions....

first off. i cleaned my spindles and ground the back side for the caliper brackets to sit flush. the drivers side is sitting perfect in my opinion and the passenger side "looks" flush. i measured the spindles and it basically says that i am supposed to use the smaller bearings with the races already in the rotors, greased up the bearings and installed seals and installed rotors. The drivers side rotor is touching the spindle steering arm. The only thing i can think is to grind the arm down a little bit. the passenger side isnt touching it but its pretty damn close.

Their instructions say tighten the nut up till it doesnt spin freely then back it off still it does. I perfer torque specs!!!!! i dont know how much to back it off to achieve the "free" movement. there probally a full turn in between tight and no play. and also with it all the way installed the cotter pin barely makes contact with the nut cover.

Has anyone had these problems?


im getting my rear axles turned down today while im at work (hope i dont get caught on company time) so they can fit in the rear rotors. and my axle bearings feel "ok" so i probally wont replace them.

Good news is i got my wheels today and look awesome. just cant fit them until i get my brakes on. hopefully they fit lol.
 

·
Registered
Joined
·
580 Posts
What sort of wheels did you finally go with Garreeto?

Looking forward to a pic.
 

·
Registered
Joined
·
1,506 Posts
There is some grinding that has to be done to get the bracket to sit flush. Did you already do the grinding? Also, this a bolt on kit where you use the oem spindles...right?
 

·
Registered
Joined
·
218 Posts
Discussion Starter · #5 ·
yea, i ground the back of them. im talking about the front of the arm. the backside of the rotor is rubbing.
 

·
Registered
Joined
·
1,506 Posts
Wow, I never had any problems. MP is really good about answering tech questions though. I called them prior to purchase and they answered all of concerns. You should give them a call. Sorry I am not more help.
 

·
Registered
Joined
·
218 Posts
Discussion Starter · #7 ·
i did. the instructions say that if you have the smaller spindle to use the bearings with the races in the rotors, and if you have the larger spindle you have to chage the races, well now the guys telling me i need to chage the races regardless. well see, im going to be pissed because i went and bought new seals cause i knocked the others in already. if it doesnt work......... lets hope it does!


oh and fat 64, i went with 17 X8s all the way around. well see if tyhe front works. hope they do.
 

·
Registered
Joined
·
1,506 Posts
GOOD LUCK!
 

·
Registered
Joined
·
144 Posts
What brand wheels did you go with ?
I'm currently running Magnum 500s and I think they will work, but I'm looking for a more open, 5-spoke design.
Thanks,

RR
 
1 - 10 of 10 Posts
Top