Ford Muscle Cars Tech Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I've got an 83 grand marquis. original owner,100k, 5.0. throttle body carb, Nothing has ever been replaced, always ran good. Engine has gradually start running like crap. First it use to stall once n a while, ,now you can feel the engine cutting out at all speeds, stallling at red lights, making turns, with foot off gas, etc. using tons of gas,. When it stalls, I have to pump some gas up, otherwise sounds like it's out of gas. It does start right up when cold. Mechanis say it's too old for them to remember. I've done all that tune up stuff,fuel filter, but I don;'t want to start replacing stuff unless I know what. Mechanics and dealer say there is no code reader to read computer. The only thing I can think is that I had dual exhast put on a few yrs back, seemed that was when it started, but just could be in my mind! I haven't found anyone that knows these old engines. Any tips will help as this was my dads car and will stay in the family.

Thanks.
 

·
Premium Member
Joined
·
141 Posts
Bad fuel pump? Check fuel pressure.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I'll put a gauge on the fitting at the throtle body. I have pushed in the shrader valve, looks like a tire stem valve, and fuel shoots out. I did notice while idling, i can hear some clicking nosie when it "coughs", sounds like its the injectors making the clicking noise? At the same time, the throttle,idle positioner adjusts at the same time.Thanks for a reply, I am determined to figure this out.!
 

·
Premium Member
Joined
·
1,107 Posts
Seem to remember some of those cars having trouble with the crankshaft timing sensor? Don't know how to check it though.
 
1 - 5 of 5 Posts
Top