Ford Muscle Cars Tech Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
My battery took a crap this winter in the 64 Gal. So I picked up a new one today and installed. After installing cables to terminals (I did the correct terminals too :D) I heard a slight hum and started to smell something like burnt wire. I felt the terminals to see if they were hot and they were not.

5 minutes later the generator started smoking like crazy. The car was never even started yet.
What could be wrong?
 

·
Registered
Joined
·
86 Posts
Discussion Starter #7
The parts store wants to know if its Autolite or Motorcraft. They say it makes a difference. How can I tell? I dont see anything on the generator or voltage regulator.
 

·
Registered
Joined
·
5,337 Posts

·
Registered
Joined
·
5,337 Posts
:confused:

I gave you the STANDARD IGNITION PN.

Make sure you tell the counter dude the cataloging is incorrect as to AMP as F says they are all the same.
 

·
Premium Member
Joined
·
34,853 Posts
:confused:

I gave you the STANDARD IGNITION PN.

Make sure you tell the counter dude the cataloging is incorrect as to AMP as F says they are all the same.
Unless you have a lot of power options the 25-30 amp is the one all the non power Optioned vehicles got. Then you jump to 40 amps.

Then in the Alternator age is when it all went crazy amperage wise, but they generally stayed around 50-55 amps.

That PN K gave you is perfect for your car.
 

·
Registered
Joined
·
5,337 Posts
Regardless,

The GEN VR is mechanical and will most likely need adjustment (in addition to polarizing) when put int service.
 
1 - 18 of 18 Posts
Top