Ford Muscle Cars Tech Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
521 Posts
Discussion Starter #1
alrighty then.. i'm having a slight problem/s with my cougar.
first off... the idle control pulley apparently is not spinning as it should be so my belt is melting. i haven't broken it yet, but i know i need to fix the problem asap.
now what i was thinking was.. hey if i need to replace the pulleys i could get some underdrive pulleys and get a bit more power out of it. well i have been looking mainly at unorthodox racing pulleys. but it would probably be just the crank pulley that i would replace, therefore my problem of the idle control pulley would still exist. so then i was thinking that i might just have to pull that pulley off and "rebuild" or give it new bearings or somethign like that. i'm not quite sure on that.
i would still like to possibly get an u/d pulley setup on it, but i am not sure if i should.
the second problem, and this one is kinda freaking me out. occasionally (today was the 2nd time its done it) when i start the car, it is almost like it is running on 5cylinders instead of 6. you know how a car is kinda crappy when you switch plug wires or one isn't connected? that is how it feels. today when it did it my battery and i believe my alternator lights were on. i turned it off (was at a red light) and turned it back on again this time it died on me. i tried it one more time it ran like it was missing for a second and then cleared up and ran fine the rest of the way home. can anybody give me any insight as to either or both of these problems. the cougar is my daily driver as all my money is going into my maverick, so i dont need my daily down.
thank you very much
Jason
 
1 - 1 of 1 Posts
Top