Ford Muscle Cars Tech Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
417 Posts
Discussion Starter #1
Need to get legitimately on the road!!

After my recent car-wreak, I have been hauling ass fixing up this 1987 ex-chp mustang I bought recently. I got to the turn-signal problem it has….(NONE WORK!) and am STUMPED!! I have done the obvious thing:
(1)flashers and fuses I took from a buddies working car and swapped over for trouble-shooting purposes,
(2)bought a Brand New turn signal arm and switch from Ford

damn! no change!!

-the hazard switch works and all the four corner lights work in this mode.

HELP ME I DON’T KNOW WHAT THE HE#K!!!!

 

·
Registered
Joined
·
218 Posts
I'm going off memory here, but I think you have two flashers in that car. One for you hazards and the other for turn signals. Have you tried swapping out both of them?

If I'm wrong, I'm sure somebody will quickly correct me.

Have a good day!
Michael
 

·
Registered
Joined
·
296 Posts
This may be abosutley incorrect but for some dumb reason if a bulb is blown I think they stop blinking. For shits and giggles test your bulbs and the connections they seat in.
 

·
Registered
Joined
·
417 Posts
Discussion Starter #5
damn! Thanks for the replys! I was not sure if I would recieve any help or if others had the same problem, but I suppose that this is the great power of these forums!

Thanks!
 

·
Registered
Joined
·
2 Posts
It sound like you have checked the basics. HAve you checked for power at the turn signal switch ? do you have power out of the switch? Also check the connector to the turn signal switch, they are bad about having broken connector locks. I would also check that all the pins in the connectors are seated correctly. Just looked at alldata Power is from fuse #5 then to turn signal flasher. Check for power in and out of flasher pink/orange wire in and light blue out. Then it goes into the hazrd switch and back out. Alldata shows for 87 that both wies are light blue. Then it goes into the turn signal switch. So check for power at all of these connections, out of the switch it branches off into 4 circuits. two for the right and two for the left. So check for power here also.
 

·
Registered
Joined
·
18 Posts
hey guys i got a 91 lx i am having the exact same problem!!!! hazards work and all marker lights and head lights and brake lights work just no turn signals ... the lights dont even go bright with the turn signal arm ingauged. all bulbs and fuses are fine can any body help???
 

·
Banned
Joined
·
6,355 Posts
I'm going off memory here, but I think you have two flashers in that car. One for you hazards and the other for turn signals. Have you tried swapping out both of them?

If I'm wrong, I'm sure somebody will quickly correct me.

Have a good day!
Michael
might be on to somethinng . OP remove the flasher you swap . 4 ways still work ?
 

·
Registered
Joined
·
18 Posts
ok guys i have the answer for you ive had the same problem in my 91 mustang for a couple months now and i finally figured it out after i replaced everything, i put a new wiring harness in a few months back had headlights,parking lights,brake lights, but no turn signals, i had hazards too,but ! the flasher in the fuse box is only for your hazards!!! the turn signal relay is on the passenger side under the glove box area its a clear see thru 2 pin circular relay that runs your turn signals! replace it or if you don't have one like i did put one in and bam!!! you will have turn signals!! best of luck to you guys !
 
1 - 14 of 14 Posts
Top