Ford Muscle Cars Tech Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter #1
I have a 1970 ltd that I am trying to get back to storage without trailering it because as we all know, who wouldn't rather drive! The problem is I replaced all of the rear brake lines and the brakes were bled and great, but now I stand on the pedal and hardly get any slowing down. I was thinking that perhaps the vacuum works with the power brakes and maybe I have a leak there? The vacuum still works partially because the headlights still go up and down (but they do not stay down), any ideas would be appreciated.
 

·
Premium Member
Joined
·
5,864 Posts
Make sure there is a good vacuum going into the booster. Won't do much good if the booster is shot, though. That's all I know.

Maybe someone with manual brakes could tell you how to bypass the power set-up and give you enough brakes to get home.
 

·
Registered
Joined
·
217 Posts
Not only is the booster suspect, but it sounds like you might have a rusted thru vacuum canister and/or a disfunctional one-way vacuum valve. Not to mention the one-way check valve that supplies the vacuum booster itself. All these parts have to be checked. Many of the ventilation system components use vacuum motors which are supplied by the big coffee can-looking reservoir AFTER the engine shuts down. So if they aren't working, your car is either not generating any/enough vacuum, or the vacuum is not being captured by the system. Start isolating all of the various components, starting with pinching off or plugging the big vacuum hose to the booster. BTW, the engine would not be running too sweet either with all the "lost" vacuum.
 

·
Registered
Joined
·
2,924 Posts
Dose the brake pedal drop when the car is first started? If you put your foot on the brake when starting and if the pedal goes down, then the booster is working. The brakes will still work of the booster failed, but will require a very heavy foot. Maybe bleeding the lines is required again. If they worked before you changed something, then it is quite likely the problem is something you did when changing the stuff you changed.
 
1 - 5 of 5 Posts
Top