Ford Muscle Cars Tech Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Proportion valve

dont ask why i need to know,its a long story.when you put a dual master cyclinder on a 66 galaxie with drum brakes can you use a proportion valve without hurting anything?im trying to find out why my disc brake swap isnt working and im doing a process of illimination to find the problem.
 

·
Registered
Joined
·
830 Posts
Proportion valve

if you are going from drums to disc it is recomended that you use a proportioning valve. Your dual master cylinder has two resivours one feeds the front disc the other the rear drums the lines go into the valve then splits to the front/ back. are you using a stock or after market vALVE?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Proportion valve

i had the disc on it,kept having problems with either not getting all the air out,or maybe a bad master cyclinder,caliper or god only knows what.so i pulled the rotors and calipers off and put the drums back on without any other changes.same basic problem with the pedel still going just about to the floor and just doesnt feel right.pulling the valve off and then the master cyclinder back off in the morning and put the stock mc back on and see what happens.ive worked on fords for 30 plus years and never had any thing wup me like this has.and the bad thing is it will be something minor causing the whole problem but i will figure it out.
 

·
Premium Member
Joined
·
1,874 Posts
Proportion valve

I agree with sleepysal when you do the change some times the pushrod in the master cylinder is too short and sometimes it's too long. This might be the problem.I have a propotioning valve on My 64.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #6 ·
Proportion valve

going to measure that today also and see if that could be the problem.i noticed last night when i did a test drive that the pedal seed right until i felt something sorta break lose as i hit the breaks and now the pedal is right back like it was.so maybe the rod is too short and pushing the cylinder to far and causing the problem or this brand new mc has a problem.anyway,thanks for the input and im going back at it again today.
 
1 - 6 of 6 Posts
Top