Ford Muscle Cars Tech Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
814 Posts
Discussion Starter · #1 ·
The other day I found my missing GoPro. Turned out it had some in car video that I had never seen before (1st pass ever with the Jerico). When watching the video I'm a little surprised by what I see on the tach. You can actually see it pretty good in full screen. Looks like I'm pretty much driving in about a 1500rpm window. Is that normal? I would have expected rpm to drop a little on launch but it pretty much stays the same. I think the pass was 6.90 @ 101.

68 Cougar in car Old Dominion 2012 - YouTube
 

·
Registered
Joined
·
5,030 Posts
Hey Cain, its been a long time since I have seen you around.

My tach has a recorder and I get similar movements as you do. I launch at 5700 and shift at 6400. The tach drops down to 5200 during a gear change after hitting 7K when using the clutch. I go through the traps at 6700 so my window is even smaller than yours. I run 1/4 mile, but my most recent 1/8 mile slip shows [email protected]

I assume that the drop is minimal (which is desirable) because our motors are back in gear when while the torque at the sweet spot in the power band.

It is odd appearing (but not inconceivable) that the tach doesn't seem to move on launch and yet you can hear what sounds like the motor bogging a little. You must have had the ideal amount of clutch slippage dialed in.

BTW, nice video! I enjoyed the short ride.
 

·
Registered
Joined
·
136 Posts
The other day I found my missing GoPro. Turned out it had some in car video that I had never seen before (1st pass ever with the Jerico). When watching the video I'm a little surprised by what I see on the tach. You can actually see it pretty good in full screen. Looks like I'm pretty much driving in about a 1500rpm window. Is that normal? I would have expected rpm to drop a little on launch but it pretty much stays the same. I think the pass was 6.90 @ 101.

68 Cougar in car Old Dominion 2012 - YouTube

Nice Job

The motor rpm sound low to me. Is it an FE engine?
I couldn't see the tach.
 

·
Registered
Joined
·
7,499 Posts
Nice Job

The motor rpm sound low to me. Is it an FE engine?
I couldn't see the tach.
View it in full screen, and then click the little gear at the bottom of the frame, and choose a higher resolution to make the details more clear.

Nice run, Cain!

Good Luck!
 

·
Premium Member
Joined
·
814 Posts
Discussion Starter · #6 ·
Hey Cain, its been a long time since I have seen you around.

My tach has a recorder and I get similar movements as you do. I launch at 5700 and shift at 6400. The tach drops down to 5200 during a gear change after hitting 7K when using the clutch. I go through the traps at 6700 so my window is even smaller than yours. I run 1/4 mile, but my most recent 1/8 mile slip shows [email protected]

I assume that the drop is minimal (which is desirable) because our motors are back in gear when while the torque at the sweet spot in the power band.

It is odd appearing (but not inconceivable) that the tach doesn't seem to move on launch and yet you can hear what sounds like the motor bogging a little. You must have had the ideal amount of clutch slippage dialed in.

BTW, nice video! I enjoyed the short ride.
Are you racing any Pro Stick events this year? Do they still not allow nitrous?
 

·
Registered
Joined
·
5,030 Posts
Are you racing any Pro Stick events this year? Do they still not allow nitrous?
Yes, I plan on hitting a bunch like Capitol, Budd's Creek, PRW (Pittsburgh), Mason Dixon and of course the 4 events at my home track. This year MIR happens to be a 2 day event, held in conjunction with the East coast stick nationals. The VA ones are just too far for me to travel this year . . . . .

Sorry in keeping somewhat true to 60's style racing that the owner likes, Prostick still doesn't allow nitrous or other power adders.
 
1 - 7 of 7 Posts
Top