Ford Muscle Cars Tech Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
Ok, here is the engine
75 351 block bore 60 over
JE Pistons 11 to 1
Scat 3.85 stroker crank
Scat H-Beam rods
Main Cap Gridle
J302 ported heads (flow= 270 int. 206 ext. @ .600)
Comp solid roller cam (.600" lift 286deg int. & 292deg ext.)
Comp pro magnum rocker & comp lifters
Victor Jr intake with 750dp holley
MSD billet dis. w/blast2 coil & Digital 6 Box)
1-3/4" Hooker headers
NX twin stage 6 nitrous system (50-300hp in each stage)

Here is the problem.
I can not get it to lean out. I have check the power valve and every thing related to the carb. No vacumm leak. Timing is locked out at 32deg. New autolite AR3933 race plugs. New motorsport 9mm wires. I have also installed and O2 sensor which is telling me the engine is rich, the blue smoke coming from the exhuast also indicates a rich condition. The carb. jet are currently 66pri. and 74 sec.

Any help would be welcomed.

Thank James
 

·
Registered
Joined
·
862 Posts
1) Is it always running rich? If not, what circuits are rich, IDLE, POWER or WOT?
2) Have you tried re-jetting and what was the result?
Carburation is always the suspect, but not always the cause.
----------------------------
Paul
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #3 ·
The factory carb jets are 70 pri and 80 sec.
I have adjusted the idle mixture to lean it out at idle (still a little rich). The four corner screws are adjust 1 turn open on the primarys and 3/4 turn on the secondarys. As soon as I get on the gas the blue smoke come and the O2 shoots to rich.

The carb has been worked over by carb shop. So I don't think it is the carb. I check the power valve with a vacumm pump. It's a 6.5 in valve and I am drawing 11 in of vaccum at idle.

What do you guys thing the timing should be?

James
 
1 - 3 of 3 Posts
Top