Ford Muscle Cars Tech Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter · #1 ·
I began cleaning up my '77 C4 valve body last night. I think there is a spring missing on the Servo Shuttle Valve. I dissassembled each valve and arranged them as I dissasembled them. When I removed the shuttle valve (same side, opposite end from the intermediate servo acc. valve) there was no spring. The valve was just flopping back and forth. The tranny did smoke the high/rev clutches if that makes a difference. My drawing is for a C5 and shows a spring to force the valve out against the retaining plate. Do I need to find a spring or will it be Okay to leave as is?
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #3 ·
Okay, I have a ASTG C5 manual. That may be where I'm getting confused. I used to have an excellent book from my school days. I believe my wife donated it to the Goodwill by mistake when we were moving.

So should I try to dissable the valve or try it as is?
 

·
Premium Member
Joined
·
4,512 Posts
If you need i can scan a c4 v.b diagram for you and email but i will need your address. It is morning here now i could do it tonight.
I'd have to look it up again but from memory a c5 does have a spring in the cutback.
You could check http://www.burly4x4.com/tech/ has some pics also.

<font size=-1>[ This Message was edited by: gregaust on 2/24/06 4:03am ]</font>

<font size=-1>[ This Message was edited by: gregaust on 2/24/06 4:04am ]</font>
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top