Ford Muscle Cars Tech Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter · #1 ·
My lifters won't compress. They are Comp Cam's. When I bring the nut of the rocker arm just until it touches the pushrod and try and tighten 1/2 turn then my valve starts to open. I'm on TDC, verified by the distributer and removed spark plug. I have let it sit for a few days same problem. I can start the motor with all of them adjusted to where I just touch the pushrod but it is very noisy, clatter. Should I take an old pushrod and tap it with a hammer and try and loosen up the lifter? Help! This is driving me crazy. Brand new motor
 

·
Registered
Joined
·
2,251 Posts
tighten each one tell there is no noise, then double check them, loosen them one at a time till they make noise then tighten till the noise goes away. After you have them at 0 shut it down and turn them all 1/2 turn.

works for me

what cam do you have
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #4 ·
I just verified the the valve closes after about 30 seconds with a dial indicator. I jumped the gun. What I'm having problems with is clatter. I will go back and set each cylinder at TDC and turn them 1/2. I have Edelbrock heads with guide plates and Trick Flow pushrods. Will the guide plates cause noise? I've been out of this game for awhile and noises from a new engine scare me. Oh, the cam is what Jasper Engines call a stage 2. I bought a short block from them.
 

·
Premium Member
Joined
·
4,418 Posts
What cam are you using.It's not unusual for some of the cams now with high intensity or fast lobes to have a little valvetrain noise.
 
1 - 6 of 6 Posts
Top