Ford Muscle Cars Tech Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
I can set initial at 12 or 15 and total timing still ends up being 30 degress. My guess is bad distributor. But I don't understand what could be wrong with it to stop it at 30 even when I change the initial but the vacuum advance has no problem getting it above 30 ?

Its a mallory Unilite with an accel points eliminator module in it

<font size=-1>[ This Message was edited by: 65whiteFastback on 8/26/06 4:43am ]</font>
 

·
Premium Member
Joined
·
535 Posts
On 2006-08-25 13:41, 65whiteFastback wrote:Its a mallory



Seriously though, you didn't mention whether or not it uses vacuum advance or is totally advanced mechanically. I had a Mallory Unilite Comp 9000 that was all mechanical so I'll assume yours is too.

It may not be a bad dizzy but rather it may just need to be recurved with a spring kit, Mallory sells them. Or in a worse scenario the weights could be sticking and need to be cleaned and freed up so they can throw out entirely.
_________________
There is a fine line between a hobby.... and mental illness.





<font size=-1>[ This Message was edited by: ZephyrZ7 on 8/26/06 5:19am ]</font>
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #3 ·
yes it has a vacuum advance as mentioned in my earlier post it has no problem going past 30 degree's with the vacuum advance hooked up thats why I am stumped
 

·
Premium Member
Joined
·
535 Posts
On 2006-08-25 14:47, 65whiteFastback wrote:
yes it has a vacuum advance as mentioned in my earlier post it has no problem going past 30 degree's with the vacuum advance hooked up thats why I am stumped
my fault, I missed the final few words or so of your original post, thats what I get for getting in a hurry. Since it goes past 30 with the vacuum advance hooked up I fail to see the problem (or maybe I just dont understand it), it sounds as if its working as it should to me.


_________________
There is a fine line between a hobby.... and mental illness.



<font size=-1>[ This Message was edited by: ZephyrZ7 on 8/26/06 6:16am ]</font>
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #5 ·
The vacuum advance works as it should but thats for cruising. But at wide open throttle vacuum has dropped to nothing. I need about 32-34 degrees for best performance at that point.
 

·
Premium Member
Joined
·
723 Posts
I run a Mallory Comp9000. You are probably hitting a mechanical stop in the distributor. There are tabs under the plates that can be bent to stop total tiimg from advancing too far. Might be your hold up?
 
1 - 7 of 7 Posts
Top