Ford Muscle Cars Tech Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
2,216 Posts
Discussion Starter · #1 ·
I had to hire someone to help me because it was a 2 man job. We put the new brass proportioning valve on and all the lines hooked up perfect with no adapters. We found a line at the MC that was not flared correctly and it had been pulling in air for ages.

The rear bleeders were rusted shut so we drilled out the holes and flushed until the fluid came out clear. After quite a bit of brake bleeding my truck has a great brake pedal now. Due to the rust in the rear I'm keeping an eye on my slave cylinders in case one or the other starts to leak.

I got my combo valve from Dave's Bronco Graveyard. The only thing I haven't figured out is that apparently my brake light hook up has 2 wires and the cap on the new valve only has 1 wire. Don't know what to do about that yet.


I'm having to re-learn how to drive my old truck around because now just a little leg on the brake pedal is all it takes.
 

·
Registered
Joined
·
5,337 Posts
I got my combo valve from Dave's Bronco Graveyard. The only thing I haven't figured out is that apparently my brake light hook up has 2 wires and the cap on the new valve only has 1 wire. Don't know what to do about that yet.
They just gave you the wrong pigtail hookup. Either request the correct one or it can usually be found at a large parts jobber.
 

·
Premium Member
Joined
·
2,216 Posts
Discussion Starter · #3 ·
I haven't studied this yet in any detail but that cap on the new valve is plastic with the single pin down in there. I don't see how any 2 pin plug will work with that. It is astronomical how much I do NOT know.
 

·
Premium Member
Joined
·
3,669 Posts
I haven't studied this yet in any detail but that cap on the new valve is plastic with the single pin down in there. I don't see how any 2 pin plug will work with that. It is astronomical how much I do NOT know.
i assume your two wire connector has a positive and a negative...
and if you touch the two together the brake warning light goes on in dash...
if im correct, then its should just be a matter of connecting the positive to new pigtail and ground the other wire....
you may not have to ground the other wire since combo valve may only be the needed path for ground....
touch the positive to metal and see if light goes on...
worst senario ,you pop a fuse....then you'll know.....
 

·
Premium Member
Joined
·
2,216 Posts
Discussion Starter · #5 ·
And now the water pump appears to be leaking :(

Yah it is most likely a ground. No bulb in there anyway so I'm just going to let it go for now.
 
1 - 5 of 5 Posts
Top