Ford Muscle Cars Tech Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I have been working on the steering column of a 67 Galaxie. When I replaced the wiring within the column, I ended up with one red wire left. Once I removed the old wires, and inserted the new, there were no other slots to place it. It is a solid red wire, which I'm assuming is used to power something.
Does anyone know if the wire is necessary in my 67?
Thanks.
 

·
Premium Member
Joined
·
509 Posts
Is it a new switch? I know the switch I bought had one extra wire then the one I pulled out (all the others matched as far as color and the extra was the odd one out). I seem to recall that it was red, I just cut it and folded it over and sealed it with some heat shrink.

'67 Mustangs use the same switch and the only thing I could figure was that was for some other application.
 

·
Premium Member
Joined
·
34,855 Posts
Is it a new switch? I know the switch I bought had one extra wire then the one I pulled out (all the others matched as far as color and the extra was the odd one out). I seem to recall that it was red, I just cut it and folded it over and sealed it with some heat shrink.

'67 Mustangs use the same switch and the only thing I could figure was that was for some other application.

X 2. If EVERYTHING works, even the Hazard lights, then cut and insulate it and forget about it.
 

·
Registered
Joined
·
1,059 Posts
I just looked at my 67. There are 10 wires going from the plug up to the switch, none of them are red. X2 on what was said, cut and insulate.
 
1 - 5 of 5 Posts
Top