Ford Muscle Cars Tech Forum banner

Won\'t Start!

999 Views 7 Replies 4 Participants Last post by  FALCONAROUND
About 2 weeks ago I got in my car to go for a quick drive and it wouldn't start. All lights and buzzers came on but no starter. No problem I thought, probably just a low battery. (car doesnt get driven much) I charged the battery, tried again.... Nothing. I finally decided to jump the posts on the starter relay just for the hell of it and... vrooom.
OK no big deal, with the original relay still in place I figured it was the root of the problem. I ordered up a new motorcraft relay, slapped it in and NOTHING!
So now I'm guessing it's possibly my ignition switch but I'm not sure I want to dig into the steering column. Anyone have experience with this? Could it possibly be something other than the ignition switch that I haven't thought of yet?
Any help would be much appreciated. Thanks
1 - 2 of 8 Posts
Check the Screws holding the IGN switch to the Column's lower end, if possible loosen them and slide it upward and try it then, if still no worky worky then lower it a little and if it still no worky worky then get a new one.... Make SURE TO BYPASS THE Neutral Safety switch first... if that's bad the ignition will do the same thing as showing a bad switch!

Cool Beans!

1 - 2 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.