Brake question on my 67 F250 - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 06-27-2004, 12:58 AM Thread Starter
Registered User
 
Join Date: Apr 2003
Posts: 582
Brake question on my 67 F250

Today coming home from work I noticed my brake pedal became hard and when I shifted to neutral it was VERY noticable that my brakes were still applied even though I didn't have my foot on the pedal. When I got in the driveway I checked the brakes and they were all hot. This has happened a few times before but I am having a hard time tracking it down. I am suspecting the distribution block, maybe the check valves are sticking. this has power drum brakes on it and I rebuilt the brakes about a year and a half ago. Any other ideas? Thanks!
AlanCasida is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome